blob: 77c258e1cb592a0625d778f5127ad164d0a94cb3 [file] [log] [blame]
name: analyzer
version: 4.2.0-dev
description: This package provides a library that performs static analysis of Dart code.
sdk: '>=2.17.0 <3.0.0'
_fe_analyzer_shared: ^40.0.0
collection: ^1.15.0
convert: ^3.0.0
crypto: ^3.0.0
glob: ^2.0.0
meta: ^1.7.0
package_config: ^2.0.0
path: ^1.8.0
pub_semver: ^2.0.0
source_span: ^1.8.0
watcher: ^1.0.0
yaml: ^3.0.0
# We use 'any' version constraints here as we get our package versions from
# the dart-lang/sdk repo's DEPS file. Note that this is a special case; the
# best practice for packages is to specify their compatible version ranges.
# See also
analyzer_utilities: any
args: any
async: any
linter: any
lints: any
matcher: any
test: any
test_reflective_loader: any