rev version in prep. for publishing (#65)

* rev version in prep. for publishing

* Update CHANGELOG.md
diff --git a/.github/dependabot.yml b/.github/dependabot.yml
new file mode 100644
index 0000000..2144819
--- /dev/null
+++ b/.github/dependabot.yml
@@ -0,0 +1,8 @@
+# Dependabot configuration file.
+version: 2
+
+updates:
+  - package-ecosystem: "github-actions"
+    directory: "/"
+    schedule:
+      interval: "monthly"
diff --git a/.github/workflows/test-package.yml b/.github/workflows/test-package.yml
index df0041d..cf8e412 100644
--- a/.github/workflows/test-package.yml
+++ b/.github/workflows/test-package.yml
@@ -9,6 +9,8 @@
   schedule:
     - cron: "0 0 * * 0"
 
+permissions: read-all
+
 env:
   PUB_ENVIRONMENT: bot.github
 
@@ -22,8 +24,8 @@
       matrix:
         sdk: [dev]
     steps:
-      - uses: actions/checkout@v2
-      - uses: dart-lang/setup-dart@v1.0
+      - uses: actions/checkout@93ea575cb5d8a053eaa0ac8fa3b40d7e05a33cc8
+      - uses: dart-lang/setup-dart@6a218f2413a3e78e9087f638a238f6b40893203d
         with:
           channel: ${{ matrix.sdk }}
       - id: install
@@ -49,8 +51,8 @@
         os: [ubuntu-latest]
         sdk: [2.15.0, dev]
     steps:
-      - uses: actions/checkout@v2
-      - uses: dart-lang/setup-dart@v1.0
+      - uses: actions/checkout@93ea575cb5d8a053eaa0ac8fa3b40d7e05a33cc8
+      - uses: dart-lang/setup-dart@6a218f2413a3e78e9087f638a238f6b40893203d
         with:
           channel: ${{ matrix.sdk }}
       - id: install
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 391fe8b..adbf55e 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,6 +1,6 @@
-## 2.1.1-dev
+## 2.1.1
 
-* Bump dependencies
+* Updated the dependency on `package:file` to require at least `6.1.3`.
 
 ## 2.1.0
 
diff --git a/README.md b/README.md
index 75f2b00..a560fb2 100644
--- a/README.md
+++ b/README.md
@@ -1,3 +1,7 @@
+[![Dart CI](https://github.com/dart-lang/glob/actions/workflows/test-package.yml/badge.svg)](https://github.com/dart-lang/glob/actions/workflows/test-package.yml)
+[![pub package](https://img.shields.io/pub/v/glob.svg)](https://pub.dev/packages/glob)
+[![package publisher](https://img.shields.io/pub/publisher/glob.svg)](https://pub.dev/packages/glob/publisher)
+
 `glob` is a file and directory globbing library that supports both checking
 whether a path matches a glob and listing all entities that match a glob.
 
diff --git a/analysis_options.yaml b/analysis_options.yaml
index fe4989b..46eee41 100644
--- a/analysis_options.yaml
+++ b/analysis_options.yaml
@@ -1,7 +1,9 @@
 include: package:lints/recommended.yaml
+
 analyzer:
   strong-mode:
     implicit-casts: false
+
 linter:
   rules:
     - avoid_empty_else
diff --git a/pubspec.yaml b/pubspec.yaml
index eae44a6..77b7904 100644
--- a/pubspec.yaml
+++ b/pubspec.yaml
@@ -1,7 +1,6 @@
 name: glob
-version: 2.1.0
-
-description: Bash-style filename globbing.
+version: 2.1.1
+description: A library to perform Bash-style file and directory globbing.
 repository: https://github.com/dart-lang/glob
 
 environment: