Prepare for the 2.10 SDK (#1307)

Bump the min SDK constraint to `2.10.0-0` so that they pick up the
`2.10` language version which is required to opt in to null safety with
the `2.10` SDKs.
diff --git a/pkgs/test/pubspec.yaml b/pkgs/test/pubspec.yaml
index 282ebe4..4de6901 100644
--- a/pkgs/test/pubspec.yaml
+++ b/pkgs/test/pubspec.yaml
@@ -4,7 +4,7 @@
 homepage: https://github.com/dart-lang/test/blob/master/pkgs/test
 
 environment:
-  sdk: '>=2.9.0-18.0 <2.9.0'
+  sdk: '>=2.10.0-0 <2.10.0'
 
 dependencies:
   analyzer: '>=0.36.0 <0.40.0'
diff --git a/pkgs/test_api/pubspec.yaml b/pkgs/test_api/pubspec.yaml
index 157497d..6afc20e 100644
--- a/pkgs/test_api/pubspec.yaml
+++ b/pkgs/test_api/pubspec.yaml
@@ -4,7 +4,7 @@
 homepage: https://github.com/dart-lang/test/blob/master/pkgs/test_api
 
 environment:
-  sdk: ">=2.9.0-18.0 <2.9.0"
+  sdk: '>=2.10.0-0 <2.10.0'
 
 dependencies:
   async: '>=2.5.0-nullsafety <2.5.0'
diff --git a/pkgs/test_core/pubspec.yaml b/pkgs/test_core/pubspec.yaml
index 6e7e886..5235507 100644
--- a/pkgs/test_core/pubspec.yaml
+++ b/pkgs/test_core/pubspec.yaml
@@ -4,7 +4,7 @@
 homepage: https://github.com/dart-lang/test/blob/master/pkgs/test_core
 
 environment:
-  sdk: ">=2.9.0-18.0 <2.9.0"
+  sdk: '>=2.10.0-0 <2.10.0'
 
 dependencies:
   analyzer: ">=0.39.5 <0.40.0"