blob: 70ce7bcec98330b8de3e2266d13460f895a735ac [file] [log] [blame]
name: test
version: 1.16.0-nullsafety.11
description: A full featured library for writing and running Dart tests.
homepage: https://github.com/dart-lang/test/blob/master/pkgs/test
environment:
sdk: ">=2.12.0-0 <3.0.0"
dependencies:
analyzer: '>=0.36.0 <0.41.0'
async: '>=2.5.0-nullsafety <2.5.0'
boolean_selector: '>=2.1.0-nullsafety <2.1.0'
coverage: '>=0.13.4 < 0.15.0'
http_multi_server: ^2.0.0
io: ^0.3.0
js: '>=0.6.3-nullsafety <0.6.3'
node_preamble: ^1.3.0
package_config: ">=1.9.2 <3.0.0"
path: '>=1.8.0-nullsafety <1.8.0'
pedantic: '>=1.10.0-nullsafety <1.10.0'
pool: '>=1.5.0-nullsafety <1.5.0'
shelf: ^0.7.0
shelf_packages_handler: ">=1.0.0 <3.0.0"
shelf_static: ^0.2.6
shelf_web_socket: ^0.2.0
source_span: '>=1.8.0-nullsafety <1.8.0'
stack_trace: '>=1.10.0-nullsafety <1.10.0'
stream_channel: '>=2.1.0-nullsafety <2.1.0'
typed_data: '>=1.3.0-nullsafety <1.3.0'
web_socket_channel: ^1.0.0
webkit_inspection_protocol: ">=0.5.0 <0.8.0"
yaml: ^2.0.0
# Use an exact version until the test_api and test_core package are stable.
test_api: 0.2.19-nullsafety.6
test_core: 0.3.12-nullsafety.9
dev_dependencies:
fake_async: ^1.0.0
shelf_test_handler: ^1.0.0
test_descriptor: ^1.0.0
test_process: ^1.0.0
dependency_overrides:
test_api:
path: ../test_api
test_core:
path: ../test_core