Remove --checked from dart --help

We no longer mention `--preview-dart-2`, we shouldn't mention
`--checked` either.

Change-Id: Ib878bf56c61f13f3ec6faacaa59ff9c7f307f7ba
Reviewed-on: https://dart-review.googlesource.com/68840
Reviewed-by: Zach Anderson <zra@google.com>
Commit-Queue: Nate Bosch <nbosch@google.com>
diff --git a/runtime/bin/main_options.cc b/runtime/bin/main_options.cc
index 114d574..f2e1e1f 100644
--- a/runtime/bin/main_options.cc
+++ b/runtime/bin/main_options.cc
@@ -137,9 +137,6 @@
   if (!Options::verbose_option()) {
     Log::PrintErr(
 "Common options:\n"
-"--checked or -c\n"
-"  Insert runtime type checks and enable assertions (checked mode, not\n"
-"  compatible with --preview-dart-2).\n"
 "--enable-asserts\n"
 "  Enable assert statements.\n"
 "--help or -h\n"
@@ -171,9 +168,6 @@
   } else {
     Log::PrintErr(
 "Supported options:\n"
-"--checked or -c\n"
-"  Insert runtime type checks and enable assertions (checked mode, not\n"
-"  compatible with --preview-dart-2).\n"
 "--enable-asserts\n"
 "  Enable assert statements.\n"
 "--help or -h\n"