Update to 1.1.0-g3, which has the API of 2.0.0 but works with Dart SDK 1.23.0-dev.9.0 (#10)

5 files changed
tree: c83f9d4238e1cb7f0d339d0db1d20504886fbc0b
  1. .analysis_options
  2. .gitignore
  3. AUTHORS
  4. CHANGELOG.md
  5. CONTRIBUTING.md
  6. LICENSE
  7. README.md
  8. dev/
  9. lib/
  10. pubspec.yaml
  11. test/
README.md

Platform

Build Status - Coverage Status -

A generic platform abstraction for Dart.

Like dart:io, package:platform supplies a rich, Dart-idiomatic API for accessing platform-specific information.

package:platform provides a lightweight wrapper around the static Platform properties that exist in dart:io. However, it uses instance properties rather than static properties, making it possible to mock out in tests.