Fix newly enforced package:pedantic lints (#111)

- always_declare_return_types
- annotate_overrides
- omit_local_variable_types
- prefer_conditional_assignment
- prefer_if_null_operators
- prefer_single_quotes
- use_function_type_syntax_for_parameters

Ignore prefer_collection_literals lints since they would require
incorrect code where a `{}` (statically a `Map`) is assigned to a static
`LinkedHashMap`. See https://github.com/dart-lang/linter/issues/1649
22 files changed
tree: a3c5ec601d52cd3430397b4bf12f45b50943e078
  1. .gitignore
  2. .test_config
  3. .travis.yml
  4. CHANGELOG.md
  5. LICENSE
  6. README.md
  7. analysis_options.yaml
  8. lib/
  9. pubspec.yaml
  10. test/
README.md

This is a pure Dart HTML5 parser. It's a port of html5lib from Python.

Usage

Parsing HTML is easy!

import 'package:html/parser.dart' show parse;
import 'package:html/dom.dart';

main() {
  var document = parse(
      '<body>Hello world! <a href="www.html5rocks.com">HTML5 rocks!');
  print(document.outerHtml);
}

You can pass a String or list of bytes to parse. There's also parseFragment for parsing a document fragment, and HtmlParser if you want more low level control.