support the latest analyzer
diff --git a/CHANGELOG.md b/CHANGELOG.md
index fafaf84..f14a303 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,4 +1,9 @@
+## 0.4.2+4
+
+* Update to work with analyzer 0.29.x and transform_test 0.2.x
+
 ## 0.4.2+3
+
 * Update to work with analyzer 0.28.x.
 
 ## 0.4.2+2
diff --git a/pubspec.yaml b/pubspec.yaml
index 506f1d6..2f43a52 100644
--- a/pubspec.yaml
+++ b/pubspec.yaml
@@ -1,12 +1,12 @@
 name: code_transformers
-version: 0.4.2+3
+version: 0.4.2+4
 author: Dart Team <misc@dartlang.org>
 description: Collection of utilities related to creating barback transformers.
 homepage: https://github.com/dart-lang/code-transformers
 environment:
   sdk: '>=1.0.0 <2.0.0'
 dependencies:
-  analyzer: ^0.28.0
+  analyzer: '>=0.28.0 <0.30.0'
   barback: '>=0.14.2 <0.16.0'
   cli_util: '>=0.0.1 <0.1.0'
   path: '>=0.9.0 <2.0.0'
@@ -14,4 +14,4 @@
   source_span: '>=1.0.0 <2.0.0'
 dev_dependencies:
   test: '>=0.12.1 <0.13.0'
-  transformer_test: '>=0.1.0 <0.2.0'
+  transformer_test: '>=0.1.0 <0.3.0'