Merge pull request #55 from dart-lang/add-future-or

Add type FutureOr<T> to mock SDK, and fix missing closing brace.
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 9692344..9b4bf33 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,3 +1,7 @@
+## 0.5.1+1
+
+* Updated mock SDK sources to include FutureOr<T> (and fixed a syntax error)
+
 ## 0.5.1
 
 * Resolver has a new method which can check whether an Asset is a Dart library
diff --git a/lib/src/dart_sdk.dart b/lib/src/dart_sdk.dart
index 2b56f86..4c6ca99 100644
--- a/lib/src/dart_sdk.dart
+++ b/lib/src/dart_sdk.dart
@@ -262,6 +262,8 @@
   'dart:async': '''
         class Future<T> {
           Future then(callback) {}
+        }
+        class FutureOr<T> {}
         class Stream<T> {}
   ''',
   'dart:html': '''
diff --git a/pubspec.yaml b/pubspec.yaml
index 139e938..8896ef2 100644
--- a/pubspec.yaml
+++ b/pubspec.yaml
@@ -1,5 +1,5 @@
 name: code_transformers
-version: 0.5.1
+version: 0.5.1+1
 author: Dart Team <misc@dartlang.org>
 description: Collection of utilities related to creating barback transformers.
 homepage: https://github.com/dart-lang/code-transformers