[browser] revert 0.10.0, it had the wrong SDK lower bound

R=sigmund@google.com

Review URL: https://codereview.chromium.org//202803002

git-svn-id: https://dart.googlecode.com/svn/branches/bleeding_edge/dart@34062 260f80e4-7a28-3924-810f-c04153c831b5
diff --git a/README.md b/README.md
index fa96851..32c736c 100644
--- a/README.md
+++ b/README.md
@@ -1,8 +1,3 @@
-This package contains dart.js, and previously contained interop.js
-
-dart.js
-=======
-
 The dart.js file is used in Dart browser apps to check for native Dart support
 and either (a) bootstrap Dartium or (b) load compiled JS instead.  Previously,
 we've recommended that you add a script tag pointing the version of dart.js in
@@ -25,15 +20,3 @@
 In this case, you will need to update it yourself as necessary.  We reserve the
 right to move the old file in the repository, so we no longer recommend linking
 to it directly.
-
-interop.js
-==========
-
-This script was required for dart:js interop to work, but it is no longer
-needed. The functionality is now supported by dart:js directly.
-
-If you previously had a script such as this, please remove it:
-
-```html
-<script src="packages/browser/interop.js"></script>
-```
diff --git a/lib/interop.js b/lib/interop.js
index ec02e58..d7c7de6 100644
--- a/lib/interop.js
+++ b/lib/interop.js
@@ -2,8 +2,9 @@
 // for details. All rights reserved. Use of this source code is governed by a
 // BSD-style license that can be found in the LICENSE file.
 
-// TODO(jmesserly): remove this script after a deprecation period.
-if (typeof console == "object" && typeof console.warn == "function") {
-  console.warn('<script src="packages/browser/interop.js"> is no longer ' +
-      'needed for dart:js. See http://pub.dartlang.org/packages/browser.');
+// Type for remote proxies to Dart objects with dart2js.
+// WARNING: do not call this constructor or rely on it being
+// in the global namespace, as it may be removed.
+function DartObject(o) {
+  this.o = o;
 }
diff --git a/pubspec.yaml b/pubspec.yaml
index e51235f..870f3a5 100644
--- a/pubspec.yaml
+++ b/pubspec.yaml
@@ -1,8 +1,8 @@
 name: browser
-version: 0.10.0
-author: "Dart Team <misc@dartlang.org>"
+version: 0.10.0+1
+authors: ["Dart Team <misc@dartlang.org>"]
 homepage: http://www.dartlang.org
 description: >
  The bootstrap dart.js script for Dart apps running in the browser.
 environment:
-  sdk: ">=1.2.0 <2.0.0"
+  sdk: ">=0.8.10+6 <2.0.0"