Update dev_dependencies on build_* (#66)

Also renamed changelog to follow convention
Also updated dart-setup in CI
diff --git a/.github/workflows/test-package.yml b/.github/workflows/test-package.yml
index e55702c..cdc25d9 100644
--- a/.github/workflows/test-package.yml
+++ b/.github/workflows/test-package.yml
@@ -23,9 +23,9 @@
         sdk: [dev]
     steps:
       - uses: actions/checkout@v2
-      - uses: dart-lang/setup-dart@v0.1
+      - uses: dart-lang/setup-dart@v1.0
         with:
-          channel: ${{ matrix.sdk }}
+          sdk: ${{ matrix.sdk }}
       - id: install
         name: Install dependencies
         run: dart pub get
@@ -47,12 +47,12 @@
       matrix:
         # Add macos-latest and/or windows-latest if relevant for this package.
         os: [ubuntu-latest]
-        sdk: [dev]
+        sdk: [2.12.0, dev]
     steps:
       - uses: actions/checkout@v2
-      - uses: dart-lang/setup-dart@v0.1
+      - uses: dart-lang/setup-dart@v1.0
         with:
-          channel: ${{ matrix.sdk }}
+          sdk: ${{ matrix.sdk }}
       - id: install
         name: Install dependencies
         run: dart pub get
diff --git a/changelog.md b/CHANGELOG.md
similarity index 92%
rename from changelog.md
rename to CHANGELOG.md
index 688b3db..3fe742a 100644
--- a/changelog.md
+++ b/CHANGELOG.md
@@ -1,3 +1,5 @@
+## 2.0.1-dev
+
 ## 2.0.0
 
 - Stable null safety release.
diff --git a/pubspec.yaml b/pubspec.yaml
index 7a57cca..702a84d 100644
--- a/pubspec.yaml
+++ b/pubspec.yaml
@@ -1,15 +1,14 @@
 name: benchmark_harness
-version: 2.0.0
-author: Dart Team <misc@dartlang.org>
+version: 2.0.1-dev
 description: The official Dart project benchmark harness.
-homepage: https://github.com/dart-lang/benchmark_harness
+repository: https://github.com/dart-lang/benchmark_harness
 
 environment:
-  sdk: '>=2.12.0-0 <3.0.0'
+  sdk: '>=2.12.0 <3.0.0'
 
 dev_dependencies:
-  build_runner: ^1.1.0
-  build_web_compilers: '>=1.0.0 <3.0.0'
-  path: ^1.8.0-nullsafety
-  pedantic: ^1.10.0-nullsafety
-  test: ^1.16.0-nullsafety
+  build_runner: ^2.0.0
+  build_web_compilers: ^3.0.0
+  path: ^1.8.0
+  pedantic: ^1.10.0
+  test: ^1.16.0