Require Dart 3.2, pub dependencies, cleanup analysis_options (#97)

* Require Dart 3.2, pub dependencies, cleanup analysis_options

* oops
diff --git a/.github/workflows/test-package.yml b/.github/workflows/test-package.yml
index 0278631..8a8eb2d 100644
--- a/.github/workflows/test-package.yml
+++ b/.github/workflows/test-package.yml
@@ -47,7 +47,7 @@
       matrix:
         # Add macos-latest and/or windows-latest if relevant for this package.
         os: [ubuntu-latest]
-        sdk: [2.19.0, dev]
+        sdk: [3.2, dev]
     steps:
       - uses: actions/checkout@b4ffde65f46336ab88eb53be808477a3936bae11
       - uses: dart-lang/setup-dart@b64355ae6ca0b5d484f0106a033dd1388965d06d
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 7111004..ce0c0eb 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,3 +1,7 @@
+## 2.2.3-wip
+
+- Require Dart 3.2.
+
 ## 2.2.2
 
 - Added package topics to the pubspec file.
diff --git a/analysis_options.yaml b/analysis_options.yaml
index eb193c7..df02e5f 100644
--- a/analysis_options.yaml
+++ b/analysis_options.yaml
@@ -7,14 +7,9 @@
 
 linter:
   rules:
-    - avoid_returning_null
-    - avoid_returning_null_for_future
     - avoid_unused_constructor_parameters
     - cancel_subscriptions
-    - comment_references
     - literal_only_boolean_expressions
     - no_adjacent_strings_in_list
     - package_api_docs
-    - prefer_const_constructors
-    - test_types_in_equals
     - unnecessary_await_in_return
diff --git a/pubspec.yaml b/pubspec.yaml
index abee9c9..adc5f6d 100644
--- a/pubspec.yaml
+++ b/pubspec.yaml
@@ -1,5 +1,5 @@
 name: benchmark_harness
-version: 2.2.2
+version: 2.2.3-wip
 description: The official Dart project benchmark harness.
 repository: https://github.com/dart-lang/benchmark_harness
 
@@ -7,11 +7,11 @@
  - benchmarking
 
 environment:
-  sdk: '>=2.19.0 <3.0.0'
+  sdk: ^3.2.0
 
 dev_dependencies:
   build_runner: ^2.0.0
-  build_web_compilers: ^3.0.0
-  dart_flutter_team_lints: ^1.0.0
+  build_web_compilers: ^4.0.0
+  dart_flutter_team_lints: ^2.0.0
   path: ^1.8.0
   test: ^1.16.0